Milkyway - ATI Flavour

Forum rules
User avatar
robmacagain
Boinc Warrant Officer Class 2
Boinc Warrant Officer Class 2
Posts: 322
Joined: Tue Apr 12, 2011 3:53 pm
Location: Sassenachshire

#51 Re: Milkyway - ATI Flavour

Post by robmacagain »

Is anyone else having problems with this project????

It keeps yo yoing between 64% and 100% constantly and when it goes to 100% it slows my card down to 500mhz from a 1000mhz, i have played with the app_config file and no matter what i do it won't stop doing it, i have reset it as well, its slowing it right down and its freezing the gpu sometimes and i have to re boot the pc to make it go again :evil:.

If i can't stop it i will have to bin the project, all the rest i do run flawless its twisting my head :cry:.
Milky way.

Image
image hosting over 5mb

And here is Collatz, perfect.

Image
photoupload
Image
User avatar
Silver
Boinc Brigadier
Boinc Brigadier
Posts: 2210
Joined: Sun Apr 14, 2013 7:09 pm
Location: Aberdeen/Anguilla

#52 Re: Milkyway - ATI Flavour

Post by Silver »

Hi Rob

I think I might have had that problem before but I honestly can't remember now :oops:
Alez was kind enough to write up some guidance before, might be worth having a look at his posts
http://www.dunadd.co.uk/seti/forum/view ... 474#p16474

How many units are you trying to run at the same time per gpu?
Image
User avatar
Alez
[ TSBT's Pirate ]
[ TSBT's Pirate ]
Posts: 10363
Joined: Thu Oct 04, 2012 1:22 pm
Location: roaming the planet

#53 Re: Milkyway - ATI Flavour

Post by Alez »

I think it's caused by the power save function in certain drivers. The clocks hit max, but at max you are only pushing 50 % usage, so the power save downclocks, but when you downclock you are now pushing 100 % usage so the clocks ramp up. It seems to be a particular problem with 290's. I believe there is a fix but as I don't have one didn't pay attention.
Any hoo I had exactly the same on primegrid with my nvidias. Doesn't look pretty on the graph but worse it was causing the cooling fans to surge which couldn't be doing them any good. The solution was to run 2 units concurrently on each gpu to keep the load high.
I presume this is on Milkyway tasks. The seperation tasks are usually more stable. Which driver are you using for the cards ?
Image
The best form of help from above is a sniper on the rooftop....
User avatar
scole of TSBT
Boinc Major General
Boinc Major General
Posts: 5978
Joined: Mon Feb 03, 2014 2:38 pm
Location: Goldsboro, (Eastern) North Carolina, USA

#54 Re: Milkyway - ATI Flavour

Post by scole of TSBT »

In another thread you showed 4 concurrent tasks per GPU, with 3 GPUs. Is that the config you are using here?
Image
User avatar
robmacagain
Boinc Warrant Officer Class 2
Boinc Warrant Officer Class 2
Posts: 322
Joined: Tue Apr 12, 2011 3:53 pm
Location: Sassenachshire

#55 Re: Milkyway - ATI Flavour

Post by robmacagain »

Well i was running 4 on each gpu of the 7990 the 7750 has not been put back in the system just yet.

It was running fine and all i have changed is to put a water block on the gpu but everything else runs just fine without this problem.

I have took the app_config file off and it still did it, its that 100% power save whatsit, i need to find the solution and for now i have retired the project until i can find that solution as it was annoying in the extreme.

Am using catalyst 13.12, been using that for yonks.
Image
User avatar
scole of TSBT
Boinc Major General
Boinc Major General
Posts: 5978
Joined: Mon Feb 03, 2014 2:38 pm
Location: Goldsboro, (Eastern) North Carolina, USA

#56 Re: Milkyway - ATI Flavour

Post by scole of TSBT »

When you removed the config, did you 1) re-read config files 2) wait until all tasks completed that were pending before the config change. When a task starts, it makes a copy of the app configuration in a slots folder. It will use those settings. Need to wait until new tasks start to make sure new config being used, I think.

Though the only thing I can think of that might be different and make a difference is you now don't have fans plugged into the GPU. Is anything plugged into the old fan plugs? If not, could that be confusing the GPU? Even if it is, I don't have any suggestions to prevent that.

Consider trying catalyst 14.4?
Image
User avatar
scole of TSBT
Boinc Major General
Boinc Major General
Posts: 5978
Joined: Mon Feb 03, 2014 2:38 pm
Location: Goldsboro, (Eastern) North Carolina, USA

#57 Re: Milkyway - ATI Flavour

Post by scole of TSBT »

Check out the comments in this acticle...http://www.techpowerup.com/195941/amd-r ... .html?cp=3

Search for "disable ULPS". It's how to disable the power save feature. Here's the gist...
The 99% usage on GPU2 is a bug caused by ULPS. ULPS is supposed to be a power saving feature for crossfire, but hasn't been working correctly for many Catalyst versions now. So, Crossfire users must disable ULPS in the registry.

How-to:
In the search field (above the Start Orb) type regedit right-click on the regedit.exe shortcut that appears -> run as admin
In Registry, on the left highlight HKEY_LOCAL_MACHINE.
Hit Ctrl+F, and in the Find field fill in: enableulps and hit Enter (or click Next) or hit F3 for next.
At Every instance of EnableUlps change the value from 1 to 0
Don't touch EnableUlps_NA
Close Registry
Reboot the PC
This is the workaround for the "99% usage on GPU2 in 3D applications (games)."- bug.
The downside is that GPU2 is no longer put to sleep mode when idle (in 2D).
Image
User avatar
robmacagain
Boinc Warrant Officer Class 2
Boinc Warrant Officer Class 2
Posts: 322
Joined: Tue Apr 12, 2011 3:53 pm
Location: Sassenachshire

#58 Re: Milkyway - ATI Flavour

Post by robmacagain »

Cheers Schole mate :) , i did find that yesterday but i did them all inc EnableUlps_NA oops, ha i read this you posted and went through again and put all EnableUlps_NA back to 1, i have not retried MW yet but will in a day or so and will report in.
Image
User avatar
Alez
[ TSBT's Pirate ]
[ TSBT's Pirate ]
Posts: 10363
Joined: Thu Oct 04, 2012 1:22 pm
Location: roaming the planet

#59 Re: Milkyway - ATI Flavour

Post by Alez »

I knew there was a solution somewhere :D I also believe that people report 12.8 as being the last stable cat release. The introduction of the r9 cards seems to have effected quite a few of the drivers for the Hawaii and Pitcairn cards. For 69xx cards 12.8 is the last driver that will work for standard milkyway tasks although the separation tasks will work with the newer drivers.
Image
The best form of help from above is a sniper on the rooftop....
User avatar
robmacagain
Boinc Warrant Officer Class 2
Boinc Warrant Officer Class 2
Posts: 322
Joined: Tue Apr 12, 2011 3:53 pm
Location: Sassenachshire

#60 Re: Milkyway - ATI Flavour

Post by robmacagain »

:( flip, no work units wassupppp.
Image
Post Reply Previous topicNext topic

Return to “MilkyWay”